Degraded performance on the site.
Incident Report for EveryDollar
Resolved
This incident has been resolved.
Posted Apr 12, 2016 - 07:55 CDT
Monitoring
Budgets should be coming back now, we are continuing to monitor the system
Posted Apr 12, 2016 - 07:39 CDT
Identified
We're experiencing increased load on our database, so budget access may be slower than normal.
Posted Apr 12, 2016 - 03:43 CDT