Bank Integration Is Down
Incident Report for EveryDollar
Resolved
Transactions flowing again
Posted May 03, 2018 - 08:52 CDT
Identified
Our third party provider is experiencing an outage which is impacting our integration
Posted May 02, 2018 - 09:57 CDT