Site Down
Incident Report for EveryDollar
Resolved
This incident has been resolved.
Posted Jan 12, 2017 - 16:37 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2017 - 15:37 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 12, 2017 - 15:33 CST
Investigating
Team is actively diagnosing the issue.
Posted Jan 12, 2017 - 15:22 CST