Experiencing a Site Down
Incident Report for EveryDollar
Resolved
We've pinned down the issue, applied the fix and are now setting up preventative measures for the future. Thank you for your patience. #keepontracking
Posted Apr 12, 2016 - 15:15 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2016 - 15:08 CDT
Investigating
Our technical response team is actively engaged. Standby...
Posted Apr 12, 2016 - 15:03 CDT