Bank Connection Service Disruption
Incident Report for EveryDollar
Resolved
All is clearing up. Thanks for your patience.
Posted Jan 02, 2017 - 15:05 CST
Monitoring
Our fix is in place and we're now watching to make sure the connections are working properly
Posted Jan 02, 2017 - 13:54 CST
Identified
We've identified an issue displaying and registering bank accounts. We're working to get a fix in place to remedy this issue.
Posted Jan 02, 2017 - 13:00 CST